b -

FPGA simulation: ModelSim /Quest

1. Program configuration
Any changes to the simulation system parameters are made in the Tools -> Edit Preferences
menu ... The setting results should be saved in the system startup script (modelsim.tcl ).
Saving settings:
command line : write preferences <filename>

To make the settings visible every time you start the system, set the system variable
MODELSIM_TCL=< path >\ modelsim.tcl
< path > - path to the modelsim.tcl file

The MODELSIM system variable points to the default environment configuration file,
modelsim.ini. The value of this variable is particularly important when installing different
versions of the simulator in one system.

2. Project management
Creating a new project: File -> New -> Project...

ﬁ Create Project

Project Mame
24210

Project Location
D:/CADHDL,/54210 Browse. ..

Default Library Mame
work

Copy Settings From

ltechéd 10.7/modelsim.ini Browse...

* Copy Library Mappings { Reference Library Mappings

oK | Cann:el|

When a new project is created, a working library is created with the name given in the window
above (in this case work ). To create a new library or change the mapping (alias) to an existing
library, use the commands described in point 4 of this manual or in [1].

['] Exercise: create a new project called <index_no> in the working directory on the disk
indicated by the teacher (if the directory does not exist, create it); leave the default name for the
working library;
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Once you have created a design space, you can add existing HDL models to it or create new
design elements. For this purpose, you can use the wizard that starts after creating the project

(window below) or create a new source using the command Project -> Add to Project -> New
File...

ﬁ Add items to the Project

Click an the icon to add items of that type:

Add Existing File

=

Create Simulation Create Mew Folder

Close

ﬁ Create Project File

File Mame
p‘LlSt}i Browse...
Add file as type Folder
VHDL vl Top Level wl
oK | Cancel |

['] Exercise: create a new design source called 'empty'; source type 'VHDL'; leave the default
file location;

The effect of each command that modifies the structure and state of the project is visible in the
workspace:

|ﬂ| Project - D:/CADHDL /84210/84210 R
TlName |513tus |Type |Drder |Mndiﬁed
[E] pusty.vhd ? YHOL O 09/30/2015 08:15:52 ...

<

At the project creation stage, there are two tabs in the workspace: 'Project’ for source files and
their status, and 'Library' containing data on libraries seen from the project level. At the current
stage of the project, an empty " work ' library should be visible in the 'Library' tab .
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i ibrary e

T|Name Type |Path

|1l work (empty) Library D:fCADHDL (34210 fwork
ﬂ—m ahblite_axi_bridge_v1_00_a Library C:Wilimad\ 14, 6\SE_DSVISE'\nti_sel\10. 7\nte4/edk/ahblite_axi_bridc
ﬂ—m apu_fpu_vw3_10_a Library C:Wilimay 14, 6\SE_DSVISE'\nti_sel10. 7\nta4/fedk/apu_fpu_v3_10_
ﬂ—m apu_fpu_virtex5 v1_01 a Library CaWilim\ 14, 6\ISE_DSVISE Yt _se\10, 7\nta<edkfapu_fpu_virtexs
+ axiZaxi_connector_v1_00_a Library Cailim 14, 6\ISE_DSISE Yt _se\10, 7\ntad/edkfaxi2axi_connect:
ﬂ—ﬂl axi_ahblite_bridge_v1_01_a Library C:Wilinx\ 14, 6\SE_DSVISE'\nti_sel10. 7\nte4/edk/axi_ahblite_bridc

< |
I} vibrary | £¥) Proj

In addition to creating new models, you can add existing HDL files to your project to reuse design
units once defined. Existing files can be added using the Project -> Add to Project -> Existing
File... command or from the context menu of the 'Project’ window.

7 Add file to Project

File Mame

<path to vhd file> Browse...
Add file as type Folder

default ﬂ Top Lewvel 1’

" Reference from current location (* Copy to project directory

Ok | Cann:el|

['] Exercise: download the ' gates.vhd ' file from the course server and save it in any temporary
directory; add this file to the project with the ' Copy to project directory '; source type 'VHDL;
(If the file was saved in the project directory, it should be added to the project with the 'Reference
from current location '.)

The added file may contain one or more design unit models. To make them available in the
working library, the file must be compiled using the Compile -> Compile Selected (menu or
right mouse button).

‘rlName |S13tus |Ty|:|e |Order |Modiﬁed
09/30/2019 06:11:27 ...
E pusty,| Edt 0 09/30/2018 08:19:52 ...
Execute
Compile Compile Selected
Add to Project 4 Compile All
Remaowe from Project Compile Qut-of-Date
Close Project Compile Order...
Update Compile Repart...
] Compile Summary. ..
Properties...
Project Settings... Compile Properties...

The effect of the compilation command is visible in the transcription window:
# Compile of gates.vhd was successful.
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Detailed information about the operation of the command (syntax, error numbers, etc.) can be
obtained by double-clicking on the transcription window message. The circled line in the window
below shows the syntax of the command invoked by the Compile -> Compile Selected .

ﬁ ..DL/84210/gates.vhd -- Successful Compile

-- Loading package STRNDARD

-- Loading package TEXTIO

-- Loading package std_logic_lled
-- Compiling package gates_phkg

-- Compiling package body gates pkg
-- Loading package gates_pkg

-- Compiling entity and2

-- Compliling architecture dataflow
-—— Compiling entity and3

—— Compiling architecture dataflow
-- Compiling entity andd

-- Compiling architecture dataflow
-- Compiling entity ands

-- Compiling architecture dataflow

Bt i B e e I L R S |

of

of

of

of

and2

and3

and4d

ands

voom —-work work -2002 -explicit -vopt -stats=none D /CADHDL,/S4210/gates.vhd
Model Technology ModelSim SE-64 wvoom 10.7 Compiler 2017.12 Dec 7 2017

-

Close

['] Exercise: run compilation of ' gates.vhd ' file; observe the build results in the transcription
window. Note the compilation command ( vcom ) syntax shown in the first line. Check the
meaning of the -work parameter in the manual

After successful compilation, the working library shows the design units defined in the VHDL

file being compiled.

Ik ibrary s
|T1Name |T?pe |Paﬁ
=" work Library D:fCADHDL /842 10 fwork
- and2 Entity D /CADHDL /342 10/gates. vhd
T’Ll]—@ dataflow Architecture
—-HE] and3 Entity D /CADHDL /342 10/gates. vhd
dataflow Architecture
+HE] and4 Entity D /CADHDL /342 10/gates. vhd
+HE] ands Entity D /CADHDL /342 10/gates. vhd
P gates_pkg Package D /CADHDL /342 10/gates. vhd
+HE] inverter Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nand2 Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nand3 Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nand4 Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nand3 Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nor2 Entity D /CADHDL /342 10/gates. vhd
_T_|—£| nor3 Entity D /CADHDL /342 10/gates. vhd
PR s I | b r [T = e D N e |
4
|
M Library Project
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3. Simulation
The way to verify the operation of models described in hardware description languages is their
simulation. The VHDL model can be simulated using forces defined in the test environment, the
so-called testbench or using the ' force ' command of the simulator .
the Simulate -> Start Simulation ... menu.

Design I VHDL ] Werilog 1 Libraries ] SOF 1 Others 1 ﬂil
TlName |T‘5-'DE |Path j
= lfﬂ_andl Entity D /CADHDL 84210/ .
] dataflow Architecture
_-+I-_|-£| and3 Entity D /CADHDLf84210f
+ ﬂ and4 Entity D:/CADHDL /34210
+ ﬂ and5s Entity D:/CADHDL /34210
{P] gates_pkg Package D /CADHDL /84210
+HE] inverter Entity D /CADHDL /84210
+E] nand2 Entity D:/CADHDL /34210
+HE] nand3 Entity D:/CADHDL /84210
h
+HE] nand4 Entity D:/CADHDL/84210f = |
< | |
Design Unit{s) Resolution
work.and2 (dataflow) default !I
Optimization
Iv Enable optimization Optimization Options. .. |
| cancel

The simulation results can be observed in text form (transcription window) or graphically (time
waveform window). To observe time waveforms, create a graphical debugging window using
the View -> Wave command and add waveforms from the 'Objects' window to it. Select the
desired signals in the 'Objects' window and then run the Add -> To Wave -> Selected Signals
from the context menu.

Eile Edit View Add Format Tools Bookmarks Window Help

18] Wave -Defauit Z ;<] ] x|
8- s@ 8+ B0 [ O-AF || SHERE| LT 4|
| BlE-tew B o-HEAHERNE US| RRARH 8%
S [ O

£ fand2fini U -
4 fand2fin2
fand2foutl

u
_- -
L|e Maow 0,00 ns
are Gusors | ooons |[ o

] Kl o] |

0 ps to 8523 ps fand2fin1 P
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['] Exercise: run simulation for design unit 'and2' from the work library ; display the ' Wave '
window and add all signals from the 'Objects’ window to the window;

The 'force' command will be used to build forces in ModelSim . It allows you to define simple
forces, but when simulating complex systems, issuing commands via a graphical interface is too
time-consuming - Tcl scripts or force models defined in HDL are used for this purpose .

In the graphical interface of the simulator (context menu after selecting the appropriate time
course), there are two commands for defining forces:

Force ( defining single values )

— _ o
[ Force Selected Signal

Signal Mame: |s im:fand2/inl

Value: |]l

Kind
|V i Freeze  Drive " Deposit

Delay For: |IZI
Cancel After: |

QK Cancel

Clock ( defining extortion periodic )

ﬁl‘ Define Clock

—Clock Mame

|sim:/and2/in2

— offset Dty
[ 150
Period Cancel
1100 ns |
—Logic Values
High:|l Luw:|El
—First Edge

' Rising " Falling

K | Cancel|
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Please note that the above windows are dialog windows - you cannot see previously defined
enforcements in them.

['] Exercise: build forces for both inputs of gate 'and2'; use the 'force’ command to build the
sequence:

inl ->'1" lasting 20ns, '0" lasting 20ns, '1' lasting 20ns, '0" lasting 20ns

in2 ->'1" lasting 40ns, '0" lasting 40ns
Run the simulation with the run 80 ns command entered in the transcription window; observe
the simulation results in the ' Wave ' window;

4. Commands in the transcription window

The Tcl scripting language command interpreter is built into the ModelSim program interface .
This makes it easier to automate design through Tcl scripts (macros have a standard extension
of .do). Each operation described in the previous point can be performed by issuing a command
in the transcription window.

Creating a new library
command line : viib <library name>
by default, a new directory called libraries is created

Mapping a logical name to a library directory
command line : vmap <logical name> <library name>
specifying only the logical name displays the current mapping

Compilation of the selected source: Compile -> Compile Selected
command line : vcom - work <library name> -2002 - explicit <file name>
default work library name = work

Loading the simulation: Simulate -> Simulate ...
command line : vsim <library name>.< entity name > (<architecture>)

Opening windows signals : View -> Objects
line commands : view objects / view signals

Opening the Time Diagrams window: View -> Wave
line commands : view wave / view -new wave

Adding the selected signal to the results window: Add -> Wave -> Selected Signals
command line : add wave - label <label> <signal name>

Adding all signals to the results window: Add -> Wave -> Signals in Design
command line : add wave -r /*
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Activation simulation : Simulate -> Run -> Run-All
line commands : run -all

(all issued commands and messages regarding their results appear in the transcription
window; detailed description of commands in item [1] )

['] Exercise: using only the command line, perform the following operations:

- create library ' gates '

- compile the gates.vhd file into the ' gates ' library

- map the ' gates ' library to the logical name 'gates'
In the Library tab, display the contents of the 'gates’ library, is it identical to the contents of the
'gates’ library?

Using the force command

Simple device models can be tested using force commands issued from the transcription window
or saved in a macro file (.do). When simulating complex devices, this design approach is
ineffective - a more advanced test environment ( testbench ) should be used.

force < signal name > <vl1> - cancel < tc >
example : force clk 1 - cancel 100ns

clk signal at the current hierarchy level takes the value '1' when the command is run; the -
cancel switch allows you to cancel the force after a set time

? ?

0 100

force < signal name > <v1> <tl>, <v2> <t2>

example : force / uut /reset 1 10ns, 0 23ns, 1 37ns
the reset signal at the / uut level of the hierarchy takes the value '1' at 10ns from the time the
command is run, then '0" at 23ns and '1' at 37ns (relative to the time the command is run)

2 | |

10 23 37

force < signal name > <vl> <tl>, <v2> <t2> - repeat < tp >
example : force clk2 1 Ons, 0 10ns - r 100ns
-repeat (-r) switch allows you to create periodic forces with infinite duration and repetition
period tp ; the example shows the clk2 signal with a frequency of 10MHz

and a duty cycle of 10%
r -
0 10 100 110 ->
force

force command without parameters allows you to control currently defined forces, e.g.:

force - drive / cntrx / ce 0 {@0 ps } , 1 {@700 ns}
force - drive / cntrx / rst 0 {@1002 us} , 1 {@1002125 ns} , 0 {@1004400 ns}
force - drive / cntrx / clk 0 {@0 ps } , 1 {@50 ns} - repeat {@100 ns}
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5. Simulation automation
.do script files (macros) are used to automate the operation of the program
They consist of Questa [1] commands and Tcl commands .

macro example for the testowy.vhd file :
# compile test model
vcom - work work -2008 ./testowy.vhd
# load the model into the simulator
vsim test.work
# display the signals and simulation results window
view waves -title test wave
view signals
# adding all signals to the results window
add waves *
# extortion construction
force ¢ 1 0, 0 {20 ns} -r 40ns
force b 1 0, 0 40ns -r 80ns
force a 1 0, 0 {80 ns} -r 160ns
# run the simulation
run 350 ns

Download the test.vhd file from the course server and add it to the project, do not compile the
file.

['] Exercise: write a macro file that performs the following operations:

- creating a library with a logical name <student index number>

- compiling the test.vhd source into a library called <student index number>

- starting the simulator for the test model

- display of waveforms

- construction of forces and model simulation

- scaling of the results window for the entire simulation time

- use command line parameters to pass the filename and simulation time
as macro command line arguments

- lupload all sources needed to run the macro (ZIP) as well as a screenshot of the
simulation results and macro listing (PDF) to the course server

[1] Siemens EDA, Questa® SIM Command Reference Manual Including Support for
Questa Base, Software Version 2023.3, Document Revision 8.3, © 2023 Siemens.
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